WordPress 2.1.1 Vulnerability

No doubt this news will be all over before the day is out, but it is worth spreading this announcement all the same.

Long story short: If you downloaded WordPress 2.1.1 within the past 3-4 days, your files may include a security exploit that was added by a cracker, and you should upgrade all of your files to 2.1.2 immediately.

Whilst the news is that the hacked changes were installed after the 2.1.1 release, since the new version includes an unrelated security patch it is probably worth everyone upgrading their WordPress files to 2.1.2 regardless. A sad occasion for WordPress, but the exact details are as yet unknown, and hopefully this release will be dilligently applied to prevent any serious damage being done.

Random Quote

History does not repeat itself, but it does rhyme.

— Mark Twain